All Articles

Sitecore 9 Prerequisites (SIF)

The prerequisites for installing Sitecore 9 using SIF are technically detailed in the installation guide. However it’s a bit obscure. Here’s a summarised list of additional packages that need to be installed to run the SIF installation tool for Sitecore 9.

You’ll need a server running Windows Server, ideally 2016+ but 2012 R2 will work if you have Powershell 5+ installed. IIS will need to be installed as well.

  1. Microsoft ODBC Driver 11 for SQL Server
  2. Microsoft Command Line Utilities 11 for SQL Server
  3. SQL Server Data Tools in Visual Studio 2015
  4. Web Platform Installer
  5. After installing Web Platform Installer, the following packages will need to be installed: UrlRewrite2, DACFX, WDeploy36PS, SQLDOM. This command will run the installation for you. C:\Program Files\Microsoft\Web Platform Installer\WebpiCmd-x64.exe /Install /Products:UrlRewrite2,DACFX,WDeploy36PS,SQLDOM,SMO_11_0 /AcceptEula